Lumen help

Network support: Configuring MPLS circuits for failover

If you have two or more redundant Lumen® MPLS circuits, you can configure your router for failover. Configuring your router for failover ensures that if one of your Lumen circuits goes down, traffic can be routed to the other circuit(s)—keeping your system functioning properly. Doing this requires a one-time, configuration change, which you can do yourself.

 

If you have redundant circuits with Lumen and another provider, then you'll need to use a different method—like AS Path Prepending—to configure your primary/backup systems.

 

You can use BGP communities to configure your router for failover. BGP communities are used to signal a desired behavior. Just like rerouting traffic on highways, BGP can be used to reroute traffic in a network.

 

BGP has many attributes that can be used for path selection (e.g., weight, local preference, AS_PATH), and BGP evaluates these attributes in a specific order. For instance, weight is evaluated before local preference, which is evaluated before AS_PATH, and so on. When BGP evaluates two paths with the same prefix, it chooses the path with the largest local preference. (The weight attribute could impact this, as weight is evaluated before local preference. Weight is an attribute that is only used on Cisco routers. In the Lumen MPLS network, the weight attribute isn’t used.)

 

By sending a community via the external BGP session (eBGP), the CE router is signaling to the PE router to modify the local preference (LP). LP isn’t advertised between two eBGP peers. LP is a non-transitive attribute, so won’t be advertised outside of an autonomous system (AS).

 

In the Lumen network, route maps are built on every provider edge (PE) to modify LP when certain BGP communities are sent by the customer edge (CE). The local preference value is used by BGP to determine the best path. (The largest local preference wins the tiebreaker.)

 

BGP only advertises its best path to its peers, so when a BGP router has two paths for a prefix, only the path with the largest LP is advertised inside the MPLS network. In the Lumen network the following communities can be used:
 

  • 209:90 – changes LP to 90
  • 209:80 – changes LP to 80
  • 209:70 – changes LP to 70

 

When no communities are sent with a prefix, the LP will default to 100. If the DallasCE is the only CE advertising a route, then traffic can only route through the Dallas circuit.

 

Backup route diagram (step 1)

The HoustonCE sends BGP community 209:90 attached to prefix 10.10.10.0/24. The Houston PE receives the prefix with 209:90 and changes the LP to 90.

Backup route diagram (step 2)

During an outage on the Dallas circuit, the Dallas route is removed and the only remaining route is to Houston, to where traffic will re-route.

Backup route diagram (step 3)

Houston CE: Configuration before changes

!

 

interface Loopback10

 

 ip address 10.10.10.1 255.255.255.0

 

!

 

interface FastEthernet0/0

 

 description Connection to Lumen

 

 ip address 65.65.65.2 255.255.255.252

 

!

 

router bgp 65000

 

 no synchronization

 

 bgp log-neighbor-changes

 

 neighbor 65.65.65.1 remote-as 209

 

 no auto-summary

 

!

These are the commands needed to configure the HoustonCE to advertise 10.10.10.0/24 with 209:90 attached. (Command explanations are in italics.)

HoustonCE#configure terminal

Enter configuration commands, one per line.  End with CNTL/Z.

Brings you into configure mode

HoustonCE(config)#ip bgp-community new-format

Needed for proper formatting of the BGP community

HoustonCE(config)#ip prefix-list PFX-LIST-TO-CTL permit 10.10.10.0/24 Prefix list to be used in the route-map
HoustonCE(config)#route-map SEND-COMM-TO-CTL permit 10 Creates the route-map sequence 10
HoustonCE(config-route-map)#match ip address prefix-list PFX-LIST-TO-CTL

Matches only the prefix contained in the prefix-list

HoustonCE(config-route-map)#set community 209:90 Sets the 209:90 community
HoustonCE(config-route-map)#route-map SEND-COMM-TO-CTL permit 20 Permits other routes (needed as there is an implicit deny any at the end of the route-map)
HoustonCE(config-route-map)#router bgp 65000 Brings you into the BGP process to configure BGP-specific commands

HoustonCE(config-router)#network 10.10.10.0 mask 255.255.255.0

Advertises the prefix into BGP (could also use other methods such as redistribution)
HoustonCE(config-router)#neighbor 65.65.65.1 route-map SEND-COMM-TO-CTL out Applies the route-map to the neighbor in the outbound direction

HoustonCE(config-router)#neighbor 65.65.65.1 send-community

Needed as Cisco IOS doesn’t send BGP communities by default
HoustonCE(config-router)#end Brings you back to privileged EXEC mode
HoustonCE#clear ip bgp 65.65.65.1 soft out Make sure to perform a soft clear outbound so that the config changes take effect

Houston CE: Configuration output after changes

!

 

interface Loopback10

 

 ip address 10.10.10.1 255.255.255.0

 

!

 

interface FastEthernet0/0

 

 description Connection to Lumen

 

 ip address 65.65.65.2 255.255.255.252

 

!

 

router bgp 65000

 

 no synchronization

 

 bgp log-neighbor-changes

 

 network 10.10.10.0 mask 255.255.255.0

 

 neighbor 65.65.65.1 remote-as 209

 

 neighbor 65.65.65.1 send-community

 

 neighbor 65.65.65.1 route-map SEND-COMM-TO-CTL out

 

 no auto-summary

 

!

 

!

 

ip bgp-community new-format

 

!

 

!

 

ip prefix-list PFX-LIST-TO-CTL seq 5 permit 10.10.10.0/24

 

!

 

route-map SEND-COMM-TO-CTL permit 10

 

 match ip address prefix-list PFX-LIST-TO-CTL

 

 set community 209:90

 

!

 

route-map SEND-COMM-TO-CTL permit 20

 

!