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S2P Browser Setup and System  
Requirements 

SHL Group Limited 2011. All rights reserved. SHL is a trademark of SHL Group Limited. 

Note: If your operating system is Windows NT 4.0, 2000, XP, Vista, or Windows 7, you must be logged into Windows as the 
local administrator before making any of the changes below. 
 
Configuration involves three processes: checking for correct settings, installing required components, and verifying settings 
using the Browser Analyzer. 

 

CHECKING SETTINGS 
 

Supported Browsers 

Internet Explorer   Version 6.0 and higher (Windows PC Only) 
Firefox    Version 2.0 and higher (Windows PC or Mac) 
Safari    Version 4.0 and higher (Mac only) 
Google Chrome   Version 4.0 and higher (Windows PC or Mac) 
 
Some test types require specific browsers: 

� Simulation tests that use the SHL simulation player require Windows-based Internet Explorer.  These include MS 
Office simulation tests, the Basic Computer Literacy test, and many Call Center Scenario tests. 

� Tests with audio work with all supported browsers and require Flash 8.0 or higher. 
� Non-simulation tests work with all supported browsers. 
� Call Center simulation tests that require Flash work with all supported browsers. 

 
Not Supported: Netscape, the AOL browser, and net appliances.  However, those with AOL may use it to connect to the 
Internet.  When connected, minimize AOL and open Internet Explorer and navigate to http://www.Select2Perform.com. 

 

Screen Resolution  

Recommended: 1024x768 or higher 
If the resolution is set to 800x600, the user will need to scroll on most screens and a low screen resolution message will appear.  
Some tests may not function correctly at an 800x600 resolution.  To change your resolution, click Start, Settings, Control 
Panel, Display, and then Settings. 

 

Audio Files 

Tests that use audio files will first look for Adobe Flash version 8 or higher.  If Flash is found, the system will use it to play the 
audio in the test (unless the test uses the SHL simulation player).  If Flash 8 or higher is not found or if the Flash version is 
older, the system will attempt to use Windows Media Player 6.0 or higher (only for PC-based Internet Explorer).  If your version 
of Windows does not include Windows Media Player, you may download it from: 
 
http://windows.microsoft.com/en-US/windows/downloads/windows-media-player  

 
Flash may be installed (or uninstalled, if needed) using information found here: 
 
http://service.shl.com/s2p/index.php?action=showEntry&data=1148  

 

Browser Security Settings 

Recommended: Medium default-level security.   
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To set this security level, open Internet Explorer, click the Tools menu, and then click Internet Options (In Internet Explorer 7 
or higher, if you don’t see the Tools menu, click the down arrow next to Tools on the right and then click Menu Bar).  Select the 
Security tab.  If not already selected, click Internet in the white box.  If the security level slider is active, click it and move the 
slider to Medium level security.  If the slider is not active, click the Default Level button. 

 
If your company does not allow this security level, and you plan to administer tests that require the SHL simulation player, then 
click the Tools menu, Internet Options, and the Custom Level button.  The following ActiveX controls should be set to 
Enable: Download signed ActiveX controls, Run ActiveX controls and plug-ins, and Script ActiveX controls marked 
safe for scripting.   
 

Browser and Session Cookies 

Recommended: Enabled 
 
Internet Explorer:  
Internet Explorer cookie settings may be changed by clicking the Tools menu, Internet Options, Privacy tab, then the 
Advanced button (If needed, to display the Menu Bar in IE 7 or higher, click the down arrow next to Tools and then click Menu 
Bar).   

 
Firefox:  
In the top left corner, click the down arrow next to the word Firefox in the orange box.  Click Options and then select the 
Privacy tab.  Enable cookies here, if needed. 
 

Browser Text Size 

Recommended: Medium 
 

Internet Explorer:  
To ensure that Internet Explorer is using the correct text size, click the View menu, Text Size, then Medium.  Medium is the 
default text size for Internet Explorer (If needed, to display the Menu Bar in IE 7 or higher, click the down arrow next to Tools 
and then click Menu Bar). 

 
Firefox:  
In the top left corner, click the down arrow next to the word Firefox in the orange box.  Click Options and then the Content tab.  
Make certain the default font is Times New Roman, size 16. 

 

Browser Temporary Internet Files Settings: 

Recommended: Under the Tools menu > Internet Options > General tab > Browsing History section > Settings button:  
� Automatically should be selected.   
� Disk Space To Use: 120 (or greater).   

 
In IE 6, select the Tools menu, Internet Options, the General tab, and then the Settings button. 

  

Internet Explorer Zoom Level: 

When using Internet Explorer 7 or higher, select the View menu, then Zoom.  The value 100% should be selected. 
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Browser Security - Make Select2perform.com a Trusted Site: 

Select the Tools menu, Internet Options, and then the Security tab.  In the Select a web content zone box (labeled Select a 
zone to view or change in IE 7 or higher), click on the green Trusted Sites circle (or check mark).  Click the Default Level 
button if it’s not grayed out and then move the slider on the left to Low.  It is important you only do this when the Trusted Sites 
option is selected.  Click the Sites button.  In the field labeled Add this web site to the zone, type www.select2perform.com 
(Do not type http:// or https:// in front of the address).  Uncheck the Require Server Verification check box.  Click the Add 
button on the right.  Click OK (or Close in IE 7 or higher).  Click the next OK.  You’re finished!   

 

Proxy Servers and Caching Devices 

Select2Perform will work with most proxy servers; however, rules should be set up on the proxy server(s) so that they will not 
cache content from *.select2perform.com (64.74.205.10) and *.previsor.com.  In many cases, these changes will not be 
needed (as long as Internet Explorer has its temporary Internet Files settings set to Automatically.  SHL Technical Support can 
provide a document that explains how to make the needed changes in Microsoft’s ISA proxy.  Proxy II is not supported.  Call 
Technical Support if you use any of the following proxy servers: Blue Coat or Proxy II. 
 

Disabling Pop-Up Blocker Programs 

Programs that stop pop-up ads can interfere with the operation of Select2Perform and should be disabled before testing.  Pop-
up blockers are often hidden in the browsers, anti-virus programs, Internet security suites, anti-spyware programs, and add-on 
toolbars.  For help disabling most pop-up blockers (both in Windows and in toolbars), please visit: 
http://service.shl.com/s2p/index.php?action=showEntry&data=1147  

 
Newer versions of Internet Explorer include a pop-up blocker that is active by default.  This pop-up blocker may interfere with 
some of Select2Perform’s functions.  SHL recommends turning off the Microsoft pop-up blocker.  To do this, open Internet 
Explorer, select the Tools menu, select Pop-up Blocker, and then click Turn Off Pop-up Blocker (If needed, to display the 
Menu Bar in IE 7 or higher, click the down arrow next to Tools and then click Menu Bar).  

 
To turn off the pop-up blocker in Firefox, select the Tools menu and then Options.  Under the Content icon, make certain 
Block Popup Windows is not checked. 
 

Disabling IE 9’s ActiveX Filtering: 

Under IE 9’s Tools menu, make certain ActiveX Filtering is not checked.  If it is checked, tests requiring Flash and the SHL 
Simulation Player will not function. 
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SPAM Filters in Mail Applications 

Programs that filter out SPAM may interfere with Select2Performs’s notification emails.  Add IP address 64.74.205.17 or email 
addresses s2padmin@PreVisor.com and s2perror@PreVisor.com to the filter's white list for each administrator.  This will allow 
administrators to receive email notifications from Select2Perform. 

 

Settings for Simulation Assessments in Windows Vista or Windows 7 

When using Windows Vista or Windows 7, either right-click the Internet Explorer icon (under Start/Programs) and select Run 
as administrator, or instead, turn off User Account Control (UAC) for the logged in user.  If this is not done, tests containing 
simulations may not work properly or the system may ask the user to install the simulation player repeatedly.  See this link for 
detailed information: http://service.shl.com/s2p/index.php?action=showEntry&data=1147.  Please see the attached documents 
on this page. 
    

INSTALLING COMPONENTS 
 

Simulation Player Plug-in Installation 

Some simulation tests require a simulation player plug-in installation.  If you do not plan on administering tests that require the 
SHL simulation Player, then you will not need to install this player.  Tests that require this player include MS Office simulations, 
Call Center Scenario tests, and Basic Computer Literacy tests.  If you log into the workstation with administrator rights, the plug-
in will automatically install during administration of the first simulated test.  

 
If the workstation is locked down (users do not have administrator rights), you must install the player on all the machines before 
administering any simulation tests. Download the player from 
http://service.shl.com/s2p/index.php?action=showEntry&data=1114 and save it to a directory or your desktop. Then, with all 
programs closed including Internet Explorer, log in to Windows as Local Administrator and run the simulation player installer 
(currently simplayer20e.exe).  You may then check to make certain the plug-in is operating properly by navigating to 
http://service.shl.com/s2p/index.php?action=showEntry&data=1579 and choose the second link in the list.  If you see an 
animation and the text Version 2.0, your simulation player is working properly.   
 

User Rights for Simulation Player  

SHL recommends that all users have Power User or Local Administrator level security rights in Windows when they test.  If 
Windows security must be stricter, make certain that all users have Full Control permissions in the temporary internet files 
folder as well as the windows (or winnt)\system32\macromed folder (and its subdirectories) and for the file windows (or 
winnt)\awshkwv.ini (created by the simulation player installation).  The macromed folder is one created by the installation of 
the Simulation Player, as explained above. 

 

Registry Setting for Simulation Player – Critical for Windows XP and Windows 98 
Users 

There is a rare Windows focus issue that affects only Windows XP and sometimes, in rarer circumstances, Windows 98 (call us 
if you use Windows 98). This issue can prevent candidates from being able to type into certain fields when testing in a simulated 
environment and may even make a test respond incorrectly when a mouse is used.  This problem is caused when another 
program changes the default registry setting.  If you use Windows XP and are logged in with administrator rights, download and 
run the following program: previsorfocuscheck.exe 
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http://service.shl.com/ts/index.php?action=showEntry&data=1187  
 
Once the program is running, click the top Check Value button to check the Registry Foregroundlocktimeout value.  If the 
value shown is 0 or 7B, click the bottom button in the utility to change the value to 30D40 (the correct value).  Reboot your PC.  
After the PC has rebooted, check the value again.  The new value should appear (30D40).  If the value has changed back to 
something other than 30D40, please call SHL Technical Support at 800-966-0943 and press 1.   
 
Also, changing your screen resolution from 800x600 to 1024x768 (by right-clicking a blank area of your desktop, choosing 
Properties, and then by clicking the Settings tab) may help with this issue.  

 

Java Virtual Machine Installation (Only required if using NETg or SkillSoft 
training) 

NETg training courses require the installation and use of a Java Virtual Machine (JVM) plug-in.  Many versions of Windows 
already include this plug-in.  To determine if you have a JVM installed, open Internet Explorer and go to 
http://service.shl.com/ts/index.php?action=showEntry&data=1579.  Choose the link that checks for a JVM.  The System Check 
screen appears.  In the Browser Information window, make certain that the Java Enabled line displays Yes: Microsoft Corp 
1.1.4.  If the line displays No or if the number displayed is less than 1.1.4, you will need to install a current JVM.   

 
To install or update a JVM, close the System Check screen. Go to 
http://service.shl.com/ts/index.php?action=showEntry&data=1566.  Click the appropriate JVM link for the version of Windows you 
are using. When prompted, click Run/Open and follow its installation instructions.  SHL recommends the Microsoft JVM build 
3809 or higher (MSJAVX86.exe).     

 
Sun JVMs: If the System Check screen indicates that you are using a Sun JVM, SHL recommends that you disable it and 
install the Microsoft JVM (if needed).  To disable the Sun JVM, click the Tools menu at the top of Internet Explorer. Next, click 
Internet Options then the Advanced tab.  Uncheck the Java Sun option, click OK, then restart Internet Explorer.  If you or your 
company must use a Sun JVM, SHL supports and recommends Sun’s JVM build 1.3.1_04.  Other Sun JVMs may work as well.  
Contact SHL Technical Support for additional information about using other Sun JVMs. 

 

VERIFYING SETTINGS USING THE BROWSER ANALYZER 

 Once Internet Explorer has been set up and configured on each workstation, use the Browser Analyzer to verify that everything 
is working properly while logged into Windows using the username of your test administrator(s).  To access the Browser 
Analyzer, use the following steps: 
  

1. Open Internet Explorer 
2. Go to http://service.shl.com/ts/index.php?action=showEntry&data=1579  
3. If you wish to check the simulation player within the analyzer, click Analyze your browser by clicking here (with 

simulation player checker).  Otherwise, click Alternative link that does not install the simulation player. 
  
Once the Browser Analyzer has opened, a green checkmark will indicate items that passed, and a red X will indicate items that 
did not pass.  For further information on why a particular item did not pass, click the Information button to the right of the red X.   
  
If you want to submit this information to SHL Technical Support: 

1. Fill in your Name and Phone number.   
2. In the Comments field, please enter the name of any Tech Support representatives who may be assisting you and 

enter a detailed description of the issue you’ve encountered.   
3. Next, select your country: 

� An email will be sent to the location closest to the country you choose in the email form. 
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� To contact SHL Technical Support in the U.S. by phone, call 800-899-7451 option 1 or 770-650-8011 
4. Next, click Submit.  This will email the browser check screen to SHL Technical Support. 

  

SELECT2PERFORM SYSTEM REQUIREMENTS 
 

Computer Processor Intel Pentium processor 500 MHz or higher (or equivalent)  
Operating System Windows 98, Windows Me, Windows NT 4.0, Windows 2000, Windows XP, Windows 

Vista, or Windows 7.  When using Windows Vista or Windows 7 with simulation tests, 
disable User Account Control.  

Memory 64 MB RAM for Windows 98/Me 
128 MB RAM for Windows NT/2000/XP 
1 GB RAM for Windows Vista  

Screen Resolution  A screen resolution of 1024x768 is recommended.  Lower resolutions may cause scrolling 
issues where candidates have to scroll to view the entire page.  Some tests may not work 
correctly when using a resolution less than 1024x768. 

Sound For tests that play audio files, Flash version 8.0 or higher is required (or if using PC-based 
Internet Explorer, Windows Media Player 6.0 or higher is allowed) plus a sound card, and 
speakers or headphones. SHL recommends using headphones that have volume control 
on the cord.   

Internet Connection For modem access the Internet, 56K will provide the minimum acceptable connection 
speed. A connection of 300K or higher is recommended for simulation tests.  

Browser PC-based Internet Explorer 6.0 and higher, Firefox 2.0 and higher (PC or Mac), Safari 4.0 
and higher (Mac only), and Google Chrome 4.0 and higher (PC and Mac).  As explained 
above, some tests require a specific browser.  
  
We recommend setting www.select2perform.com as a trusted site in IE by selecting the 
Tools menu, Internet Options, Security tab, Trusted Sites icon in the white box, Sites 
button, typing www.select2perform.com, and clicking OK (If needed, to display the Menu 
Bar in IE 7 or higher, click the down arrow next to Tools and then click Menu Bar).  
 
Additionally, if tests containing simulations will be used, the following ActiveX settings 
should be set to Enable:  

� Downloaded signed activex controls 

� Script activex controls marked safe for scripting 

� Run activex controls and plug-ins  
 
To download Internet Explorer, navigate your browser to: 
www.microsoft.com/windows/Ie 

Internet Explorer 
Browser Settings 

Default Medium Level security is recommended 
  
Simulation tests require the SHL Simulation Player 
To download it, navigate your browser to: 
http://service.shl.com/s2p/index.php?action=showEntry&data=1114  
 
Microsoft's Java Virtual Machine (JVM) build 3809 or Sun's Java Runtime Environment 
(JRE) is required only if you will be administering training.  A JVM is not required for 
select2perform testing. 
  
Modifying browser settings may require administrative permissions for Windows 
NT/2000/XP/Vista/Windows 7.  

Proxy servers Select2Perform will work with most proxy servers once they have been set to not cache 
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content from *.select2perform and *.shl.com.  Contact SHL Technical Support for 
additional information and exceptions. 

Rights When using the SHL Simulation Player, a user must have full permissions in the 
<windows\winnt>\system32\macromed\ folder, its subdirectories, temporary Internet 
files folder for that user, and for the file <windows\winnt>\awshkwv.ini (created by the 
simulation player). 

 


