Prism® TV app supported devices

The Prism® TV application supports a wide range of Apple, Android (including Amazon and Nook), and Roku players.

Apple iOS mobile devices

Software requirements:

  • Apple iOS version 5.1 or higher

Supported devices:

  • iPad 2, 3, and 4
  • iPad Mini 2 and 4
  • iPad Air 1 and 2
  • iPad Pro
  • iPhone 3GS, 4, 4s, 5, 5s, 6, 6s, and 6 Plus
  • iPod Touch 3rd Gen, 4th Gen, and 5th Gen
  • Apple Watch

Android mobile devices

Software requirements:

  • Android version 4.0.3 through 5.1
  • Standard wireless carrier software only (no rooted phones)

Supported devices:

  • Samsung Galaxy S3
  • Samsung Galaxy S4
  • Samsung Galaxy S5
  • Samsung Galaxy Note 2
  • Samsung SGH-T989 - Galaxy S II (phone)
  • Samsung SPH-D710 - Galaxy S II (phone)
  • Samsung Galaxy Tab 2 10"
  • Samsung Galaxy Note II LTE
  • Amazon Kindle Fire HDX 
  • Amazon Kindle Fire HD
  • Amazon Kindle Fire HD 8.9
  • Amazon Fire Phone
  • Asus Transformer Pad Infinity
  • Asus/Google Nexus 7 (OS 4.4)
  • HTC EVO 4G
  • HTC First
  • HTC One X
  • Motorola Droid RAZR M
  • Motorola ME811 - Droid X
  • Motorola XT912 - Droid RAZR
  • Google Nexus 7
    While your Prism® TV app may work with other Android devices, technical support is only provided for the devices listed in this article. If you want to use your Prism® TV app with a different Android device, use these minimum requirements as a guide.

    Minimum software requirements for non-supported Android devices:

    • Android version 2.3 and above
    • Standard wireless carrier software only (no rooted phones)

    Minimum hardware requirements for non-supported Android devices:

    • Processor speed:
    • Minimum: 1.0 GHz processor
    • Preferred: 1.2 GHz dual core processor
    • Memory (RAM):
    • Minimum: 512MB RAM
    • Preferred: 1GB RAM

    Roku

    • Streaming Stick®
    • Streaming Players (Roku 1, 2, 3)
    • 4K UHD Player (Roku 4)
    • Roku TV (models vary)

    All trademark names are property of their respective owners.